How to configure full static routing on routers

This article is all about how to configure full static routing on routers. In previous articles, we learn about basic static routing configuration on routers and also learn about configuring dynamic routings like OSPF, RIP, and EIGRP. But here we learn about configuring full static routing on routers. This is a little bit complex and time-consuming routing than others because in basic static routing configuration we only tell routers about one best path from where a router can send packets from source to destination.

Also Read: Fascinating facts about Administrative distance in Routers

But here in full static routing configuration, we tell all the possible paths to a router from which a router can send packets from source to destination. Full static routing helps a lot when a port of the router goes down then router can be able to send packets from another path while in basic static routing if a port of the router goes down then router cannot send packets from source to destination due to this sometimes network is interrupted and can not be able to send and receives packets. So we configure full static routing because if a port goes down then it can find another path to send packets o the destination and network do not interrupt and work smoothly. So we can also be able to use full static routing as temporary backup routing. So let’s start here how to configure full static routing on routers.

configure full static routing

To understand this lab perfectly we take a lab in cisco packet tracer. We do this whole lab in two simple parts, Where in the first part we assign IP address on all the interfaces of the routers. And in the second part, we configure full static routing on routers and also check whether routing is configured correctly on routers or not.

First of all, Assign IP address on all the interfaces on the routers using given below codes.

For Router R1

Router>en

Router#config t

Enter configuration commands, one per line. End with CNTL/Z.

Router(config)#host R1

R1(config)#

R1(config)#interface FastEthernet0/0

R1(config-if)#ip address 1.0.0.1 255.0.0.0

R1(config-if)#no shutdown

R1(config-if)#

%LINK-5-CHANGED: Interface FastEthernet0/0, changed state to up

%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/0, changed state to up

R1(config-if)#exit

R1(config)#interface FastEthernet0/1

R1(config-if)#ip address 2.0.0.1 255.0.0.0

R1(config-if)#no shutdown

R1(config-if)#

%LINK-5-CHANGED: Interface FastEthernet0/1, changed state to up

R1(config-if)#exit

R1(config)#interface Ethernet0/0/0

R1(config-if)#ip address 3.0.0.1 255.0.0.0

R1(config-if)#no shutdown

R1(config-if)#

%LINK-5-CHANGED: Interface Ethernet0/0/0, changed state to up

R1(config-if)#exit

R1(config)#interface Ethernet0/1/0

R1(config-if)#ip address 4.0.0.1 255.0.0.0

R1(config-if)#no shutdown

R1(config-if)#

%LINK-5-CHANGED: Interface Ethernet0/1/0, changed state to up

R1(config-if)#exit

R1(config)#

R1(config)#do write

Building configuration…

[OK]

R1(config)#

 

For router R2

Router>en

Router#config t

Enter configuration commands, one per line. End with CNTL/Z.

Router(config)#host R2

R2(config)#

R2(config)#interface FastEthernet0/0

R2(config-if)#ip address 2.0.0.2 255.0.0.0

R2(config-if)#no shutdown

R2(config-if)#

%LINK-5-CHANGED: Interface FastEthernet0/0, changed state to up

%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/0, changed state to up

R2(config-if)#exit

R2(config)#interface FastEthernet0/1

R2(config-if)#ip address 5.0.0.1 255.0.0.0

R2(config-if)#no shutdown

R2(config-if)#

%LINK-5-CHANGED: Interface FastEthernet0/1, changed state to up

R2(config-if)#exit

R2(config)#interface Ethernet0/0/0

R2(config-if)#ip address 6.0.0.1 255.0.0.0

R2(config-if)#no shutdown

R2(config-if)#

%LINK-5-CHANGED: Interface Ethernet0/0/0, changed state to up

R2(config-if)#exit

R2(config)#

R2(config)#do write

Building configuration…

[OK]

R2(config)#

 

For router R3

Router>en

Router#config t

Enter configuration commands, one per line. End with CNTL/Z.

Router(config)#host R3

R3(config)#

R3(config)#interface FastEthernet0/0

R3(config-if)#ip address 3.0.0.2 255.0.0.0

R3(config-if)#no shutdown

R3(config-if)#

%LINK-5-CHANGED: Interface FastEthernet0/0, changed state to up

%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/0, changed state to up

R3(config-if)#exit

R3(config)#interface FastEthernet0/1

R3(config-if)#ip address 7.0.0.1 255.0.0.0

R3(config-if)#no shutdown

R3(config-if)#

%LINK-5-CHANGED: Interface FastEthernet0/1, changed state to up

R3(config-if)#exit

R3(config)#interface Ethernet0/0/0

R3(config-if)#ip address 6.0.0.2 255.0.0.0

R3(config-if)#no shutdown

R3(config-if)#

%LINK-5-CHANGED: Interface Ethernet0/0/0, changed state to up

%LINEPROTO-5-UPDOWN: Line protocol on Interface Ethernet0/0/0, changed state to up

R3(config-if)#exit

R3(config)#interface Ethernet0/1/0

R3(config-if)#ip address 8.0.0.1 255.0.0.0

R3(config-if)#no shutdown

R3(config-if)#

%LINK-5-CHANGED: Interface Ethernet0/1/0, changed state to up

R3(config-if)#exit

R3(config)#

R3(config)#do write

Building configuration…

[OK]

R3(config)#

 

For router R4

Router>en

Router#config t

Enter configuration commands, one per line. End with CNTL/Z.

Router(config)#host R4

R4(config)#

R4(config)#interface FastEthernet0/0

R4(config-if)#ip address 4.0.0.2 255.0.0.0

R4(config-if)#no shutdown

R4(config-if)#

%LINK-5-CHANGED: Interface FastEthernet0/0, changed state to up

%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/0, changed state to up

R4(config-if)#exit

R4(config)#interface FastEthernet0/1

R4(config-if)#ip address 9.0.0.1 255.0.0.0

R4(config-if)#no shutdown

R4(config-if)#

%LINK-5-CHANGED: Interface FastEthernet0/1, changed state to up

R4(config-if)#exit

R4(config)#interface Ethernet0/0/0

R4(config-if)#ip address 8.0.0.2 255.0.0.0

R4(config-if)#no shutdown

R4(config-if)#

%LINK-5-CHANGED: Interface Ethernet0/0/0, changed state to up

%LINEPROTO-5-UPDOWN: Line protocol on Interface Ethernet0/0/0, changed state to up

R4(config-if)#exit

R4(config)#

R4(config)#do write

Building configuration…

[OK]

R4(config)#

 

For router R5

Router>en

Router#config t

Enter configuration commands, one per line. End with CNTL/Z.

Router(config)#host R5

R5(config)#

R5(config)#interface FastEthernet0/0

R5(config-if)#ip address 5.0.0.2 255.0.0.0

R5(config-if)#no shutdown

R5(config-if)#

%LINK-5-CHANGED: Interface FastEthernet0/0, changed state to up

%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/0, changed state to up

R5(config-if)#exit

R5(config)#interface FastEthernet0/1

R5(config-if)#ip address 7.0.0.2 255.0.0.0

R5(config-if)#no shutdown

R5(config-if)#

%LINK-5-CHANGED: Interface FastEthernet0/1, changed state to up

%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/1, changed state to up

R5(config-if)#exit

R5(config)#interface Ethernet0/0/0

R5(config-if)#ip address 9.0.0.2 255.0.0.0

R5(config-if)#no shutdown

R5(config-if)#

%LINK-5-CHANGED: Interface Ethernet0/0/0, changed state to up

%LINEPROTO-5-UPDOWN: Line protocol on Interface Ethernet0/0/0, changed state to up

R5(config-if)#exit

R5(config)#interface Ethernet0/1/0

R5(config-if)#ip address 10.0.0.1 255.0.0.0

R5(config-if)#no shutdown

R5(config-if)#

%LINK-5-CHANGED: Interface Ethernet0/1/0, changed state to up

%LINEPROTO-5-UPDOWN: Line protocol on Interface Ethernet0/1/0, changed state to up

R5(config-if)#exit

R5(config)#

R5(config)#do write

Building configuration…

[OK]

R5(config)#

After assigning the IP address to all the interfaces of the routers then we configure IP address on the PCs which are connected through the routers. Then we go to the second step.

Also Read: How to configure static routing on cisco router using serial port?

In the second step, we configure full static routing on routers so we can able to communicate with different networks in a company or an institute. So let’s start here to configure static routing on routers using given below command on the routers.

For router R1

R1(config)#ip route 5.0.0.0 255.0.0.0 2.0.0.2

R1(config)#ip route 5.0.0.0 255.0.0.0 3.0.0.2

R1(config)#ip route 5.0.0.0 255.0.0.0 4.0.0.2

R1(config)#ip route 6.0.0.0 255.0.0.0 2.0.0.2

R1(config)#ip route 6.0.0.0 255.0.0.0 3.0.0.2

R1(config)#ip route 6.0.0.0 255.0.0.0 4.0.0.2

R1(config)#ip route 7.0.0.0 255.0.0.0 2.0.0.2

R1(config)#ip route 7.0.0.0 255.0.0.0 3.0.0.2

R1(config)#ip route 7.0.0.0 255.0.0.0 4.0.0.2

R1(config)#ip route 8.0.0.0 255.0.0.0 2.0.0.2

R1(config)#ip route 8.0.0.0 255.0.0.0 3.0.0.2

R1(config)#ip route 8.0.0.0 255.0.0.0 4.0.0.2

R1(config)#ip route 9.0.0.0 255.0.0.0 2.0.0.2

R1(config)#ip route 9.0.0.0 255.0.0.0 3.0.0.2

R1(config)#ip route 9.0.0.0 255.0.0.0 4.0.0.2

R1(config)#ip route 10.0.0.0 255.0.0.0 2.0.0.2

R1(config)#ip route 10.0.0.0 255.0.0.0 3.0.0.2

R1(config)#ip route 10.0.0.0 255.0.0.0 4.0.0.2

R1(config)#

R1(config)#do write

Building configuration…

[OK]

R1(config)#

 

For router R2

R2(config)#ip route 1.0.0.0 255.0.0.0 2.0.0.1

R2(config)#ip route 1.0.0.0 255.0.0.0 6.0.0.2

R2(config)#ip route 1.0.0.0 255.0.0.0 5.0.0.2

R2(config)#ip route 3.0.0.0 255.0.0.0 2.0.0.1

R2(config)#ip route 3.0.0.0 255.0.0.0 6.0.0.2

R2(config)#ip route 3.0.0.0 255.0.0.0 5.0.0.2

R2(config)#ip route 4.0.0.0 255.0.0.0 2.0.0.1

R2(config)#ip route 4.0.0.0 255.0.0.0 6.0.0.2

R2(config)#ip route 4.0.0.0 255.0.0.0 5.0.0.2

R2(config)#ip route 7.0.0.0 255.0.0.0 2.0.0.1

R2(config)#ip route 7.0.0.0 255.0.0.0 6.0.0.2

R2(config)#ip route 7.0.0.0 255.0.0.0 5.0.0.2

R2(config)#ip route 8.0.0.0 255.0.0.0 2.0.0.1

R2(config)#ip route 8.0.0.0 255.0.0.0 6.0.0.2

R2(config)#ip route 8.0.0.0 255.0.0.0 5.0.0.2

R2(config)#ip route 9.0.0.0 255.0.0.0 2.0.0.1

R2(config)#ip route 9.0.0.0 255.0.0.0 5.0.0.2

R2(config)#ip route 9.0.0.0 255.0.0.0 6.0.0.2

R2(config)#ip route 10.0.0.0 255.0.0.0 2.0.0.1

R2(config)#ip route 10.0.0.0 255.0.0.0 6.0.0.2

R2(config)#ip route 10.0.0.0 255.0.0.0 5.0.0.2

R2(config)#

R2(config)#do write

Building configuration…

[OK]

R2(config)#

 

For router R3

R3(config)#ip route 1.0.0.0 255.0.0.0 3.0.0.1

R3(config)#ip route 1.0.0.0 255.0.0.0 6.0.0.1

R3(config)#ip route 1.0.0.0 255.0.0.0 8.0.0.2

R3(config)#ip route 1.0.0.0 255.0.0.0 7.0.0.2

R3(config)#ip route 2.0.0.0 255.0.0.0 3.0.0.1

R3(config)#ip route 2.0.0.0 255.0.0.0 6.0.0.1

R3(config)#ip route 2.0.0.0 255.0.0.0 8.0.0.2

R3(config)#ip route 2.0.0.0 255.0.0.0 7.0.0.2

R3(config)#ip route 4.0.0.0 255.0.0.0 3.0.0.1

R3(config)#ip route 4.0.0.0 255.0.0.0 6.0.0.1

R3(config)#ip route 4.0.0.0 255.0.0.0 8.0.0.2

R3(config)#ip route 4.0.0.0 255.0.0.0 7.0.0.2

R3(config)#ip route 5.0.0.0 255.0.0.0 3.0.0.1

R3(config)#ip route 5.0.0.0 255.0.0.0 6.0.0.1

R3(config)#ip route 5.0.0.0 255.0.0.0 8.0.0.2

R3(config)#ip route 5.0.0.0 255.0.0.0 7.0.0.2

R3(config)#ip route 9.0.0.0 255.0.0.0 3.0.0.1

R3(config)#ip route 9.0.0.0 255.0.0.0 6.0.0.1

R3(config)#ip route 9.0.0.0 255.0.0.0 8.0.0.2

R3(config)#ip route 9.0.0.0 255.0.0.0 7.0.0.2

R3(config)#ip route 10.0.0.0 255.0.0.0 3.0.0.1

R3(config)#ip route 10.0.0.0 255.0.0.0 6.0.0.1

R3(config)#ip route 10.0.0.0 255.0.0.0 8.0.0.2

R3(config)#ip route 10.0.0.0 255.0.0.0 7.0.0.2

R3(config)#

R3(config)#do write

Building configuration…

[OK]

R3(config)#

 

For router R4

R4(config)#ip route 1.0.0.0 255.0.0.0 4.0.0.1

R4(config)#ip route 1.0.0.0 255.0.0.0 8.0.0.1

R4(config)#ip route 1.0.0.0 255.0.0.0 9.0.0.2

R4(config)#ip route 2.0.0.0 255.0.0.0 4.0.0.1

R4(config)#ip route 2.0.0.0 255.0.0.0 8.0.0.1

R4(config)#ip route 2.0.0.0 255.0.0.0 9.0.0.2

R4(config)#ip route 3.0.0.0 255.0.0.0 4.0.0.1

R4(config)#ip route 3.0.0.0 255.0.0.0 8.0.0.1

R4(config)#ip route 3.0.0.0 255.0.0.0 9.0.0.2

R4(config)#ip route 5.0.0.0 255.0.0.0 4.0.0.1

R4(config)#ip route 5.0.0.0 255.0.0.0 8.0.0.1

R4(config)#ip route 5.0.0.0 255.0.0.0 9.0.0.2

R4(config)#ip route 6.0.0.0 255.0.0.0 4.0.0.1

R4(config)#ip route 6.0.0.0 255.0.0.0 8.0.0.1

R4(config)#ip route 6.0.0.0 255.0.0.0 9.0.0.2

R4(config)#ip route 7.0.0.0 255.0.0.0 4.0.0.1

R4(config)#ip route 7.0.0.0 255.0.0.0 8.0.0.1

R4(config)#ip route 7.0.0.0 255.0.0.0 9.0.0.2

R4(config)#ip route 10.0.0.0 255.0.0.0 4.0.0.1

R4(config)#ip route 10.0.0.0 255.0.0.0 8.0.0.1

R4(config)#ip route 10.0.0.0 255.0.0.0 9.0.0.2

R4(config)#

R4(config)#do write

Building configuration…

[OK]

R4(config)#

 

For router R5

R5(config)#ip route 1.0.0.0 255.0.0.0 5.0.0.1

R5(config)#ip route 1.0.0.0 255.0.0.0 7.0.0.1

R5(config)#ip route 1.0.0.0 255.0.0.0 9.0.0.1

R5(config)#ip route 2.0.0.0 255.0.0.0 5.0.0.1

R5(config)#ip route 2.0.0.0 255.0.0.0 7.0.0.1

R5(config)#ip route 2.0.0.0 255.0.0.0 9.0.0.1

R5(config)#ip route 3.0.0.0 255.0.0.0 5.0.0.1

R5(config)#ip route 3.0.0.0 255.0.0.0 7.0.0.1

R5(config)#ip route 3.0.0.0 255.0.0.0 9.0.0.1

R5(config)#ip route 4.0.0.0 255.0.0.0 5.0.0.1

R5(config)#ip route 4.0.0.0 255.0.0.0 7.0.0.1

R5(config)#ip route 4.0.0.0 255.0.0.0 9.0.0.1

R5(config)#ip route 6.0.0.0 255.0.0.0 5.0.0.1

R5(config)#ip route 6.0.0.0 255.0.0.0 7.0.0.1

R5(config)#ip route 6.0.0.0 255.0.0.0 9.0.0.1

R5(config)#ip route 8.0.0.0 255.0.0.0 5.0.0.1

R5(config)#ip route 8.0.0.0 255.0.0.0 7.0.0.1

R5(config)#ip route 8.0.0.0 255.0.0.0 9.0.0.1

R5(config)#

R5(config)#do write

Building configuration…

[OK]

R5(config)#

Also Read: How to configure a little complex static routing on routers having serial ports.

Now full static routing is configured on the routers. So to check this use ping command on one of the PC at least more than five times. If your PC successfully communicate with each other that means your routing is configured correctly on the routers.

PC>ping 1.0.0.2

Pinging 1.0.0.2 with 32 bytes of data:

Reply from 1.0.0.2: bytes=32 time=0ms TTL=125

Reply from 1.0.0.2: bytes=32 time=26ms TTL=123

Reply from 1.0.0.2: bytes=32 time=1ms TTL=117

Reply from 1.0.0.2: bytes=32 time=25ms TTL=125

Ping statistics for 1.0.0.2:

Packets: Sent = 4, Received = 4, Lost = 0 (0% loss),

Approximate round trip times in milli-seconds:

Minimum = 0ms, Maximum = 26ms, Average = 13ms

PC>

Also Read: Learn all the troubleshooting commands for OSPF routing protocol

Now if you want to check your routing table on one of the routers then use given below command on your routers.

R3#show ip route

Codes: C – connected, S – static, I – IGRP, R – RIP, M – mobile, B – BGP

D – EIGRP, EX – EIGRP external, O – OSPF, IA – OSPF inter area

N1 – OSPF NSSA external type 1, N2 – OSPF NSSA external type 2

E1 – OSPF external type 1, E2 – OSPF external type 2, E – EGP

i – IS-IS, L1 – IS-IS level-1, L2 – IS-IS level-2, ia – IS-IS inter area

* – candidate default, U – per-user static route, o – ODR

P – periodic downloaded static route

Gateway of last resort is not set

S 1.0.0.0/8 [1/0] via 3.0.0.1

[1/0] via 6.0.0.1

[1/0] via 8.0.0.2

[1/0] via 7.0.0.2

S 2.0.0.0/8 [1/0] via 3.0.0.1

[1/0] via 6.0.0.1

[1/0] via 8.0.0.2

[1/0] via 7.0.0.2

C 3.0.0.0/8 is directly connected, FastEthernet0/0

S 4.0.0.0/8 [1/0] via 3.0.0.1

[1/0] via 6.0.0.1

[1/0] via 8.0.0.2

[1/0] via 7.0.0.2

S 5.0.0.0/8 [1/0] via 3.0.0.1

[1/0] via 6.0.0.1

[1/0] via 8.0.0.2

[1/0] via 7.0.0.2

C 6.0.0.0/8 is directly connected, Ethernet0/0/0

C 7.0.0.0/8 is directly connected, FastEthernet0/1

C 8.0.0.0/8 is directly connected, Ethernet0/1/0

S 9.0.0.0/8 [1/0] via 3.0.0.1

[1/0] via 6.0.0.1

[1/0] via 8.0.0.2

[1/0] via 7.0.0.2

S 10.0.0.0/8 [1/0] via 3.0.0.1

[1/0] via 6.0.0.1

[1/0] via 8.0.0.2

[1/0] via 7.0.0.2

R3#

 THAT’S IT

These are the steps by which you can easily configure full static routing on routers. If you have any queries regarding this then simply solved out your queries and doubts using the comment section. Also, follow our blog for further updates and stay updated with us.

How to configure EIGRP routing protocol on Cisco routers

This article is all about how to configure EIGRP (Enhanced Interior Gateway Routing Protocol) routing on Cisco routers. It is quite easy to configure EIGRP routing protocol router than Static routing but it is less secure than Static routing. EIGRP is a distance vetor routing protocol that is based on IGRP. It is also known as hybrid routing protocol because it has characteristics of both Distance and Link state routing protocol. EIGRP offer load balancing across six paths (equal or unequal). EIGRP is Cisco proprietary that means EIGRP only works on Cisco routers. EIGRP routing protocol uses DUAL (Diffused Update Algorithm) to calculate the shortest path for the destination. So, here we learn how to configure EIGRP in simplest and easier way. 

Also Read: Fascinating facts about Administrative distance in Routers

Now we take a lab to understand this whole configuration with ease. We can use Cisco Packet Tracer as well as GNS3 software for doing this lab on your system. Here I do this whole lab in GNS3 software because Packet Tracer student only supports CCNA commands while GNS3 support all the commands which are used in CCNA as well as CCNP also. In this lab, we take three Cisco routers, three switches, three PCs and Connecting wires for performing this lab successfully. So let’s start here how to configure EIGRP routing protocol on Cisco routers. Topology diagram for this lab is given below

configure eigrp routing protocol

First of all, connect all the routers, switches and PCs using connecting wires according to the above-given diagram. After that Assign IP address on all the interfaces of the routers using given below commands

For Router R1

R1#config t

Enter configuration commands, one per line. End with CNTL/Z.

R1(config)#int fa0/0

R1(config-if)#ip address 1.0.0.1 255.0.0.0

R1(config-if)#no shut

R1(config-if)#exit

R1(config)#

*Mar 1 00:02:14.679: %LINK-3-UPDOWN: Interface FastEthernet0/0, changed state to up

*Mar 1 00:02:15.679: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/0, changed state to up

R1(config)#

R1(config)#int fa0/1

R1(config-if)#ip address 2.0.0.1 255.0.0.0

R1(config-if)#no shut

R1(config-if)#

*Mar 1 00:02:50.999: %LINK-3-UPDOWN: Interface FastEthernet0/1, changed state to up

*Mar 1 00:02:51.999: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/1, changed state to up

R1(config-if)#exit

 

For router R2

R2#config t

Enter configuration commands, one per line. End with CNTL/Z.

R2(config)#int fa0/0

R2(config-if)#ip address 2.0.0.2 255.0.0.0

R2(config-if)#no shut

R2(config-if)#exit

R2(config)#

*Mar 1 00:02:14.679: %LINK-3-UPDOWN: Interface FastEthernet0/0, changed state to up

*Mar 1 00:02:15.679: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/0, changed state to up

R2(config)#

R2(config)#int fa0/1

R2(config-if)#ip address 3.0.0.1 255.0.0.0

R2(config-if)#no shut

R2(config-if)#

*Mar 1 00:02:50.999: %LINK-3-UPDOWN: Interface FastEthernet0/1, changed state to up

*Mar 1 00:02:51.999: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/1, changed state to up

R2(config-if)#exit

R2(config)#

R2(config)#int fa1/0

R2(config-if)#ip address 4.0.0.1 255.0.0.0

R2(config-if)#no shut

R2(config-if)#

*Mar 1 00:02:50.999: %LINK-3-UPDOWN: Interface FastEthernet1/0, changed state to up

*Mar 1 00:02:51.999: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet1/0, changed state to up

R2(config-if)#exit

 

For router R3

R3#config t

Enter configuration commands, one per line. End with CNTL/Z.

R3(config)#int fa0/0

R3(config-if)#ip address 4.0.0.2 255.0.0.0

R3(config-if)#no shut

R3(config-if)#

*Mar 1 00:10:00.047: %LINK-3-UPDOWN: Interface FastEthernet0/0, changed state to up

*Mar 1 00:10:01.047: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/0, changed state to up

R3(config-if)#exit

R3(config)#

R3(config)#int fa0/1

R3(config-if)#ip address 5.0.0.1 255.0.0.0

R3(config-if)#no shut

R3(config-if)#

*Mar 1 00:10:31.711: %LINK-3-UPDOWN: Interface FastEthernet0/1, changed state to up

*Mar 1 00:10:32.711: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/1, changed state to up

R3(config-if)#exit

By these commands, IP address will be assigned to all the interfaces and all the interfaces are UP now resulting in no shut command.

Also Read: Learn all the troubleshooting commands for OSPF routing protocol

Now we configure EIGRP routing protocol on all the routers so routers can communicate with each other. For doing this use given below commands on your router.

For Router R1

R1(config)#router eigrp 1

R1(config-router)#network 1.0.0.0

R1(config-router)#network 2.0.0.0

R1(config-router)#exit

 

For router R2

R2(config)#router eigrp 1

R2(config-router)#network 2.0.0.0

R2(config-router)#

*Mar 1 00:19:17.507: %DUAL-5-NBRCHANGE: IP-EIGRP(0) 1: Neighbor 2.0.0.1 (FastEthernet0/0) is up: new adjacency

R2(config-router)#

R2(config-router)#network 3.0.0.0

R2(config-router)#network 4.0.0.0

R2(config-router)#exit

 

For Router R3

R3(config)#router eigrp 1

R3(config-router)#network 4.0.0.0

R3(config-router)#

*Mar 1 00:23:09.367: %DUAL-5-NBRCHANGE: IP-EIGRP(0) 1: Neighbor 4.0.0.1 (FastEthernet0/0) is up: new adjacency

R3(config-router)#

R3(config-router)#network 5.0.0.0

R3(config-router)#exit

Now EIGRP routing will be configured on all the routers and your routers are ready now to send packets from source to destination. So for send packets from one host to another host simply provide IP address on the PCs which are connected from routers using switches.

 

For providing IP address to the PCs in Cisco Packet tracer you can use the graphical method. But in GNS3 you can only provide IP address to a PC using Console of the PC.

 

For setting up the IP address on the PCs use given below commands.

For PC1

PC1> ip 1.0.0.2 255.0.0.0 1.0.0.1
Checking for duplicate address…
PC1 : 1.0.0.2 255.0.0.0 gateway 1.0.0.1

 

For PC2

PC2> ip 3.0.0.2 255.0.0.0 3.0.0.1
Checking for duplicate address…
PC1 : 3.0.0.2 255.0.0.0 gateway 3.0.0.1

 

For PC3

PC3> ip 5.0.0.2 255.0.0.0 5.0.0.1
Checking for duplicate address…
PC1 : 5.0.0.2 255.0.0.0 gateway 5.0.0.1

Now all the PCs and routers are configured and ready to send and receive packets. So to check whether routing is correctly installed on your routers or not you can use ping command on a PC. For example, here we ping PC1 from PC3. So we use Ping command on PC1 output is shown below

PC1> ping 5.0.0.1
84 bytes from 5.0.0.2 icmp_seq=1 ttl=64 time=1.005 ms
84 bytes from 5.0.0.2 icmp_seq=2 ttl=64 time=0.000 ms
84 bytes from 5.0.0.2 icmp_seq=3 ttl=64 time=1.003 ms
84 bytes from 5.0.0.2 icmp_seq=4 ttl=64 time=0.000 ms
84 bytes from 5.0.0.2 icmp_seq=5 ttl=64 time=0.000 ms

PC1>

If Ping is successful that means your routing is configured correctly on all the routers.

                                      THAT’S IT

These are the steps by which you can easily learn EIGRP routing protocol configuration. In the upcoming article, we learn about troubleshooting command for EIGRP routing protocol. If you found this article helpful for you then share this article with your friends and family members. If you have any queries regarding this then simply solved out through comment section. Also, follow our blog for interesting articles and stay updated with us.

Fascinating facts about Administrative distance in Routers

This article is all about Some important known facts about the Administrative distance which is used by routers to choose a path for sending a packet from one router to another router. Many of the routing protocols have metric structures and algorithms which are not compatible with other routing protocols. So in a large network which has many of the routers and routing protocols for communication, then it is very difficult to choose the best path for communication with another router because they have multiple protocols. Then at that time, Administrative distance helps a lot to choose the best path for communication. So here we learn about what is Administrative distance and how it works on routers.

Also Read: Learn binary conversion of IPv4 in dotted-decimal notation using some examples

what is administrative values

What is the Administrative distance?

In simple and easiest language we can say that Administrative distance is an important feature that is used by routers to choose the best path for communication when two or more than two routers used two different routing protocols and routes to the same destination. Administrative distance also shows the reliability of a routing protocol which is used by routers to send a packet from source to destination. All the routing protocols like Static routing, RIP routing, EIGRP routing, OSPF routing and so on are prioritized in order of most to least reliable by using the Administrative value of the routing protocols.

How Administrative distance work on routers?

Administrative distance is the first and most important criteria which are used by routers to chose the best path for routers. It only occurs when two or more than two routing protocols are used for the route to the same destination. In which one is less reliable than other. But it is only defined only by the Administrative distance so routers use Administrative distance as first criteria to select the best path. The best thing about Administrative distance is it only has local significance and not advertised in routing updates. Administrative distance is a numeric value which can be ranging from 0 to 255. And this numeric value helps a lot to choose the reliable path for communication. If Administrative distance ha smaller value than it is more reliable than other routing protocols. So according to this the best reliable and trusted Administrative value is 0 and the worst Administrative value is 255.

Also Read: How to use CDP(Cisco Discovery Protocol) on cisco routers

For example, we take a network in which two routing protocols work on the routers and routes for the same destination. In which one is OSPF routing protocol (Open Shortest Path First routing protocol) which has an Administrative value that is “100” and other is Static routing protocol which has an Administrative value that is “1“. In that case, the router chooses Static routing protocol as the best path for sending packets from source to destination. Because Static routing protocol has less Administrative value than OSPF routing protocol. That means the router adds the Static version of the route to the routing table. If Static routing protocol fails to deliver information to the destination by some technical reasons then in that case router usage OSPF routing protocol to deliver information to the destination.

Administrative values can be set by default for all the routing protocols on all the routers. Here we can learn about all the Administrative values which are used by Cisco routers.

Default Distance Value Table for Cisco Routers

This table contains the default Administrative values for various routing protocols that Cisco supports:

Routing Protocols Administrative Distance
Directly connected interface 0
Static routing protocol 1
Dynamic Mobile Network Routing (DMNR) 3
Enhanced Interior Gateway Routing Protocol (EIGRP) summary route 5
External Border Gateway Protocol (BGP) 20
Internal EIGRP 90
IGRP 100
Open Shortest Path First (OSPF) 110
Intermediate System-to-Intermediate System (IS-IS) 115
Routing Information Protocol (RIP) 120
Exterior Gateway Protocol (EGP) 140
On Demand Routing (ODR) 160
External EIGRP 170
Internal BGP 200
Next Hop Resolution Protocol (NHRP) 250
Floating Static Route (ex. default backup route) Variable–user assigned
Unknown (Others)* 255

Note: – 1. If the Administrative value is 255, then the router does not believe on the source of that route and does not install the route in the routing table. It also removes the route from the routing table on the router and not use it.

2. Directly connected routes have an administrative distance of 0.

3. You can also modify the Administrative distance of a routing protocol on the router using the distance command in the routing process subconfiguration mode. We can learn about distance command in detail in upcoming articles.

4. Only the interface itself has an administrative value of 0 until a route cannot have a distance of less than 1.

THAT’S IT

These are some important facts about the Administrative distance of the routing protocol. In the next article, we learn about how to show and configure the Administrative value of a routing protocol. If you find this article helpful then share this article with your friends and if you have any queries regarding Administrative values than simply solved through the comment section. Also, follow our blog for further updates and stay updated.

How to configure Servers(DHCP, DNS, HTTP) along with the routers.

This article is all about how to configure Servers(DHCP, DNS, HTTP) along with the routers. In the previous post, we learn about how to configure DHCP, DNS, HTTP servers in Cisco packet tracers along with the switches. But configure servers along with switches is quite easy in the comparison of configuring servers along with routers. Because along with switches servers and routers are on the same network but here in this configuration servers and users are on the different networks. Like mail server servers are present in the company but the users are present worldwide and they are able to access those servers from anywhere in the world. So here in this lab, we learn about how to configure Servers along with the routers.

Also Read:  How to configure DHCP, DNS, HTTP servers along with switches

In this lab, we take two routers, two switches, two servers one is HTTP and another is DNS, two PCs, and connecting wires. Now take one of the routers and connect it to servers and then from another router we connect PCs as the figure is given below.

how to configure Servers along with routers

We do this whole lab in two parts. In the first part, we configure routers by assigning IP addresses to all the interfaces and configure static routing on both of the routers. In the second part, we configure both of the servers and assign IP address on PCs using static routing. So let’s start here how to configure this whole lab in two parts.

PART 1: – Configuring routers

1.  Assign IP address to all the interfaces of both the routers

For router R1

Router>enable

Router#configure terminal

Enter configuration commands, one per line. End with CNTL/Z.

Router(config)#hostname R1

R1(config)#interface FastEthernet0/0

R1(config-if)#ip address 1.0.0.1 255.0.0.0

R1(config-if)#no shutdown

%LINK-5-CHANGED: Interface FastEthernet0/0, changed state to up

%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/0, changed state to up

R1(config-if)#exit



R1(config)#interface FastEthernet0/1

R1(config-if)#ip address 2.0.0.1 255.0.0.0

R1(config-if)#no shutdown

%LINK-5-CHANGED: Interface FastEthernet0/1, changed state to up

R1(config-if)#exit

 

For router R2

Router>enable

Router#configure terminal

Enter configuration commands, one per line. End with CNTL/Z.

Router(config)#hostname R2

R2(config)#interface FastEthernet0/0

R2(config-if)#ip address 2.0.0.2 255.0.0.0

R2(config-if)#no shutdown

%LINK-5-CHANGED: Interface FastEthernet0/0, changed state to up

%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/0, changed state to up

R2(config-if)#exit

R2(config)#interface FastEthernet0/1

R2(config-if)#ip address 3.0.0.1 255.0.0.0

R2(config-if)#no shutdown

%LINK-5-CHANGED: Interface FastEthernet0/1, changed state to up

%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/1, changed state to up

R2(config-if)#exit

2.  Configure static routing on both the routers using given below command

For router R1

R1(config)#ip route 3.0.0.0 255.0.0.0 2.0.0.2

 

For router R2

R2(config)#ip route 1.0.0.0 255.0.0.0 2.0.0.1

 

Part 2: – Configure both of the Servers and assign IP address on both the PCs using static method

First of all, configure DNS server by going into the DNS service configuration figure is given below

how to configure DNS server

Also, remember that provide name and IP address of the HTTP server in the DNS server as given in the figure above.

Now configure HTTP server by going into the HTTP server configuration as the figure is shown below

how to configure http servers

Also, remember that give IP address of the DNS server at the time of assigning IP on the HTTP server.

After that assign, IP address on both of the PCs using static method figure is shown below

 

How to assign IP address on the PCs

Now to check configuration using both of the PCs use ping command on routers

                                                                       THAT’S IT

This is the whole process by which we can learn about how to configure servers along with the routers. By using this process we can easily understand this configuration. I think this article is helpful for you. If you have any queries regarding this then it can simply be solved through the comment section. Also, provide feedback to us because your feedback is valuable for us. Subscribe and follow our blog for further updates.

Learn all the troubleshooting commands for OSPF routing protocol

This article is all about how to troubleshoot your OSPF routing and verify routing on the routers. In the previous article, we easily learn that How to configure OSPF routing protocol on the Cisco routers. Now in this tutorial, we learn about how to verify and check OSPF routing protocol using troubleshooting commands on routers. Now to understand these troubleshooting commands with ease we again take the previous lab which is used to understand OSPF configuration on the routers.

So, let’s start here how to check and verify your OSPF routing protocol using troubleshooting commands. If you don’t know how to configure OSPF routing protocol on the routers then read my previous article by clicking on the above-given link.

how to configure OSPF on routers

Now use given below commands on any of the routers and verify your routing. Like here I run troubleshooting commands on router R1

To display complete routing table use below-given command

R1#show ip route

Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP

D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area

N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2

E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP

i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area

∗  - candidate default, U - per-user static route, o - ODR

P - periodic downloaded static route

Gateway of last resort is not set

C 1.0.0.0/8 is directly connected, FastEthernet0/0

C 2.0.0.0/8 is directly connected, Serial0/0/0

O 3.0.0.0/8 [110/65] via 2.0.0.2, 00:02:04, Serial0/0/0

O 4.0.0.0/8 [110/128] via 2.0.0.2, 00:02:04, Serial0/0/0

O 5.0.0.0/8 [110/129] via 2.0.0.2, 00:02:04, Serial0/0/0

To display parameters of all the running protocols of the router use below-given command

R1#show ip protocols

Routing Protocol is "ospf 1"

Outgoing update filter list for all interfaces is not set

Incoming update filter list for all interfaces is not set

Router ID 2.0.0.1

Number of areas in this router is 1. 1 normal 0 stub 0 nssa

Maximum path: 4

Routing for Networks:

1.0.0.0 0.255.255.255 area 0

2.0.0.0 0.255.255.255 area 0

Routing Information Sources:

Gateway Distance Last Update

2.0.0.1 110 00:05:21

4.0.0.1 110 00:05:21

5.0.0.1 110 00:05:21

Distance: (default is 110)

 

To display OSPF routing process basic information use given below command

R1#show ip ospf

Routing Process "ospf 1" with ID 2.0.0.1

Supports only single TOS(TOS0) routes

Supports opaque LSA

SPF schedule delay 5 secs, Hold time between two SPFs 10 secs

Minimum LSA interval 5 secs. Minimum LSA arrival 1 secs

Number of external LSA 0. Checksum Sum 0x000000

Number of opaque AS LSA 0. Checksum Sum 0x000000

Number of DCbitless external and opaque AS LSA 0

Number of DoNotAge external and opaque AS LSA 0

Number of areas in this router is 1. 1 normal 0 stub 0 nssa

External flood list length 0

Area BACKBONE(0)

Number of interfaces in this area is 2

Area has no authentication

SPF algorithm executed 2 times

Area ranges are

Number of LSA 3. Checksum Sum 0x0253cb

Number of opaque link LSA 0. Checksum Sum 0x000000

Number of DCbitless LSA 0

Number of indication LSA 0

Number of DoNotAge LSA 0

Flood list length 0

To display all the OSPF neighbors of the router R1 in detail use below-given command

R1#show ip ospf neighbor detail

Neighbor 4.0.0.1, interface address 2.0.0.2

In the area 0 via interface Serial0/0/0

Neighbor priority is 0, State is FULL, 5 state changes

DR is 0.0.0.0 BDR is 0.0.0.0

Options is 0x00

Dead timer due in 00:00:35

Neighbor is up for 00:11:55

Index 1/1, retransmission queue length 0, number of retransmission 0

First 0x0(0)/0x0(0) Next 0x0(0)/0x0(0)

Last retransmission scan length is 0, maximum is 0

Last retransmission scan time is 0 msec, maximum is 0 msec

 

To display a brief list of OSPF neighbors use given below command

R1#show ip ospf neighbor

Neighbor ID Pri State Dead Time Address Interface

4.0.0.1 0 FULL/ - 00:00:31 2.0.0.2 Serial0/0/0

 

To display the detailed OSPF information on all the interfaces of router use below-given command

R1#show ip ospf interface

FastEthernet0/0 is up, line protocol is up

Internet address is 1.0.0.1/8, Area 0

Process ID 1, Router ID 2.0.0.1, Network Type BROADCAST, Cost: 1

Transmit Delay is 1 sec, State DR, Priority 1

Designated Router (ID) 2.0.0.1, Interface address 1.0.0.1

No backup designated router on this network

Timer intervals configured, Hello 10, Dead 40, Wait 40, Retransmit 5

Hello due in 00:00:07

Index 1/1, flood queue length 0

Next 0x0(0)/0x0(0)

Last flood scan length is 1, maximum is 1

Last flood scan time is 0 msec, maximum is 0 msec

Neighbor Count is 0, Adjacent neighbor count is 0

Suppress hello for 0 neighbor(s)

Serial0/0/0 is up, line protocol is up

Internet address is 2.0.0.1/8, Area 0

Process ID 1, Router ID 2.0.0.1, Network Type POINT-TO-POINT, Cost: 64

Transmit Delay is 1 sec, State POINT-TO-POINT, Priority 0

No designated router on this network

No backup designated router on this network

Timer intervals configured, Hello 10, Dead 40, Wait 40, Retransmit 5

Hello due in 00:00:07

Index 2/2, flood queue length 0

Next 0x0(0)/0x0(0)

Last flood scan length is 1, maximum is 1

Last flood scan time is 0 msec, maximum is 0 msec

Neighbor Count is 1 , Adjacent neighbor count is 1

Adjacent with neighbor 4.0.0.1

Suppress hello for 0 neighbor(s)

 

To display information about border and boundary routers use below-given command

R1#show ip ospf border-routers

OSPF Process 1 internal Routing Table

Codes: i - Intra-area route, I - Inter-area route

 

To display all the ospf events on the router use below-given command
 R1#debug ip ospf events
OSPF events debugging is on
R1#
00:19:58: OSPF: Rcv hello from 4.0.0.1 area 0 from Serial0/0/0 2.0.0.2

00:19:58: OSPF: End of hello processing

00:20:08: OSPF: Rcv hello from 4.0.0.1 area 0 from Serial0/0/0 2.0.0.2

00:20:08: OSPF: End of hello processing

00:20:18: OSPF: Rcv hello from 4.0.0.1 area 0 from Serial0/0/0 2.0.0.2

00:20:18: OSPF: End of hello processing

00:20:28: OSPF: Rcv hello from 4.0.0.1 area 0 from Serial0/0/0 2.0.0.2

00:20:28: OSPF: End of hello processing

00:20:38: OSPF: Rcv hello from 4.0.0.1 area 0 from Serial0/0/0 2.0.0.2

00:20:38: OSPF: End of hello processing

 THAT’S IT

These are the troubleshooting commands by which we can easily verify our OSPF routing protocols on the router. If you have any queries regarding this then simply solved out through the comment section and also provide feedback to us. Because your feedback is valuable to us.

Learn how to configure OSPF routing protocol on cisco routers

This article is all about how to configure OSPF routing protocol on Cisco routers. Here OSPF stands for Open Shortest Path First. OSPF is a routing protocol that uses a link state routing(LSR) algorithm and falls into the group of Interior Gateway Protocols(IGP’s) and these are operating within a single autonomous system (AS). OSPF is the most widely used IGP in the large enterprise network. Because other routing protocols like RIP and EIGRP having some limitations in it. Like RIP routing only works on 15 hop count if hope count is more than 15 then we can’t use RIP routing in that company and EIGRP routing protocol works only on Cisco routers. But OSPF routing protocol is working on the other company routers and also work on more than 15 hop count in a company. So OSPF is the most widely used protocol in the large enterprise network.

OSPF is also famous in ISP network because it’s an open standard and supports almost every vendor hardware and software. So, let’s start here how to configure OSPF routing protocol on Cisco routers.

Now to understand this whole process with ease we take a lab in cisco packet tracer. In this lab, we take four routers having serial ports in it and four PCs to check whether they are communicating properly or not using the ping command in it.

how to configure OSPF on routers

We do this whole lab in three parts in the first part we assign IP address on all the interfaces of the router. In the second part, we configure OSPF routing protocol on the routers to connect different networks in a company. In the third part, we use ping command and check whether they are communicating with each other or not.

Part 1: – Assign IP address on all the routers using given below command.

For router R1

Router>enable

Router#configure terminal

Enter configuration commands, one per line. End with CNTL/Z.

Router(config)#hostname R1

R1(config)#interface FastEthernet0/0

R1(config-if)#ip address 1.0.0.1 255.0.0.0

R1(config-if)#no shutdown

%LINK-5-CHANGED: Interface FastEthernet0/0, changed state to up

%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/0, changed state to up

R1(config-if)#exit

R1(config)#interface Serial0/0/0

R1(config-if)#ip address 2.0.0.1 255.0.0.0

R1(config-if)#clock rate 64000

R1(config-if)#no shutdown

%LINK-5-CHANGED: Interface FastEthernet0/1, changed state to up

R1(config-if)#exit

 

For router R2

Router>enable

Router#configure terminal

Enter configuration commands, one per line. End with CNTL/Z.

Router(config)#hostname R2

R2(config)#

R2(config)#interface FastEthernet0/0

R2(config-if)#ip address 3.0.0.1 255.0.0.0

R2(config-if)#no shutdown

R2(config-if)#

%LINK-5-CHANGED: Interface FastEthernet0/0, changed state to up

%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/0, changed state to up

R2(config-if)#exit

R2(config)#interface Serial0/0/0

R2(config-if)#ip address 2.0.0.2 255.0.0.0

R2(config-if)#no shutdown

R2(config-if)#

%LINK-5-CHANGED: Interface FastEthernet0/1, changed state to up

%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/1, changed state to up

R2(config-if)#exit

R2(config)#interface Serial0/0/1

R2(config-if)#ip address 4.0.0.1 255.0.0.0

R2(config-if)#clock rate 6400

R2(config-if)#no shutdown

%LINK-5-CHANGED: Interface Ethernet0/0/0, changed state to up

R2(config-if)#exit

For router R3

Router>enable

Router#configure terminal

Enter configuration commands, one per line. End with CNTL/Z.

Router(config)#hostname R3

R3(config)#interface FastEthernet0/0

R3(config-if)#ip address 5.0.0.1 255.0.0.0

R3(config-if)#no shutdown

%LINK-5-CHANGED: Interface FastEthernet0/0, changed state to up

%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/0, changed state to up

R3(config-if)#exit

R3(config)#interface FastEthernet0/1

R3(config-if)#ip address 4.0.0.2 255.0.0.0

R3(config)#interface Serial0/0/0

R3(config-if)#no shutdown

%LINK-5-CHANGED: Interface FastEthernet0/1, changed state to up

%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/1, changed state to up

R3(config-if)#exit

 

Part 2: – Configure OSPF routing on cisco routers using given below command

For router R1

R1(config)#route ospf 1

R1(config-router)#network 1.0.0.0 0.255.255.255 area 0

R1(config-router)#network 2.0.0.0 0.255.255.255 area 0

For router R2

R2(config)#route ospf 2

R2(config-router)#network 2.0.0.0 0.255.255.255 area 0

R2(config-router)#network 3.0.0.0 0.255.255.255 area 0

R2(config-router)#network 4.0.0.0 0.255.255.255 area 0

 

For router R3

R3(config)#route ospf 3

R3(config-router)#network 4.0.0.0 0.255.255.255 area 0

R3(config-router)#network 5.0.0.0 0.255.255.255 area 0

 

Part 3: – Use ping command on the PCs to check whether they are communicating with each other or not and also trace the route using tracert command on the PCs

PC>ping 5.0.0.2

Pinging 5.0.0.2 with 32 bytes of data:

Reply from 5.0.0.2: bytes=32 time=2ms TTL=125

Reply from 5.0.0.2: bytes=32 time=12ms TTL=125

Reply from 5.0.0.2: bytes=32 time=11ms TTL=125

Reply from 5.0.0.2: bytes=32 time=34ms TTL=125

Ping statistics for 5.0.0.2:

Packets: Sent = 4, Received = 4, Lost = 0 (0% loss),

Approximate round trip times in milli-seconds:

Minimum = 2ms, Maximum = 34ms, Average = 14ms



PC>tracert 4.0.0.2

Tracing route to 4.0.0.2 over a maximum of 30 hops:

1 0 ms 0 ms 1 ms 1.0.0.1

2 15 ms 28 ms 37 ms 2.0.0.2

3 1 ms 0 ms 1 ms 4.0.0.2

Trace complete.



PC>tracert 1.0.0.1

Tracing route to 1.0.0.1 over a maximum of 30 hops:

1 0 ms 0 ms 0 ms 5.0.0.1

2 1 ms 0 ms 14 ms 4.0.0.1

3 7 ms 35 ms 7 ms 1.0.0.1

Trace complete.

 THAT’S IT

This is the whole process by which we can easily configure OSPF (Open Shortest Path First) routing protocol on the routers. In next article, we learn how to troubleshoot OSPF routing protocol. If you have any queries regarding this then simply solved out through the comment section and also provide feedback to us. Because your feedback is valuable to us.

Learn binary conversion of IPv4 in dotted-decimal notation using some examples

This article is all about binary conversion of IPv4 in dotted-decimal notation using some examples. In the previous articles on IPv4, we learn about Some interesting facts of IP address and also learn what is subnet mask and how to identify subnet mask of an IP address. We also read about classes of IP address in detail. Now in this article, we learn about how to convert our IPv4 address from binary to dotted- decimal notation.

Now to understand these type of conversion we take some examples of IP addresses from IPv4 and convert then into dotted-decimal notation. So, let’s start here binary conversion of IPv4 address in dotted-decimal notation using some examples.

how to convert IP addresses into decimal-dotted notation

1.  Convert 17.34.56.7 into dotted-decimal notation and also identify subnet mask or class of this IP address.

IP address 1st bit 2nd bit 3rd bit 4th bit 5th bit 6th bit 7th bit 8th bit
128 64 32 16 8 4 2 1
17 0 0 0 1 0 0 0 1
34 0 0 1 0 0 0 1 0
56 0 0 1 1 1 0 0 0
7 0 0 0 0 0 1 1 1

This IP address belongs to class A and Its subnet mask is 255.0.0.0

dotted-decimal notation of IP address 17.34.56.7 is given below

00010001.00100010.00111000.00000111

2.  Convert 115.230.245.76 into dotted-decimal notation and also identify subnet mask or class of this IP address.

IP address 1st bit 2nd bit 3rd bit 4th bit 5th bit 6th bit 7th bit 8th bit
128 64 32 16 8 4 2 1
115 0 1 1 1 0 0 1 1
230 1 1 1 0 0 1 1 0
245 1 1 1 1 0 1 0 1
76 0 1 0 0 1 1 0 0

This IP address belongs to class A and Its subnet mask is 255.0.0.0

dotted-decimal notation of IP address 115.230.245.76 is given below

01110011.11100110.11110101.01001100

3.  Convert 120.114.67.78 into dotted-decimal notation and also identify subnet mask or class of this IP address.

IP address 1st bit 2nd bit 3rd bit 4th bit 5th bit 6th bit 7th bit 8th bit
128 64 32 16 8 4 2 1
120 0 1 1 1 1 0 0 0
114 0 1 1 1 0 0 1 0
67 0 1 0 0 0 0 1 1
78 0 1 0 0 1 1 1 0

This IP address belongs to class A and Its subnet mask is 255.0.0.0

dotted-decimal notation of IP address 120.114.67.78 is given below

01111000.01110010.01000011.01001110

4.  Convert 154.172.68.4 into dotted-decimal notation and also identify subnet mask or class of this IP address.

IP address 1st bit 2nd bit 3rd bit 4th bit 5th bit 6th bit 7th bit 8th bit
128 64 32 16 8 4 2 1
154 1 0 0 1 1 0 1 0
172 1 0 1 0 1 1 0 0
68 0 1 0 0 0 1 0 0
4 0 0 0 0 0 1 0 0

This IP address belongs to class B and Its subnet mask is 255.255.0.0

dotted-decimal notation of IP address 154.172.68.4 is given below

10011010.10101100.01000100.00000100

5.  Convert 162.6.34.87 into dotted-decimal notation and also identify subnet mask or class of this IP address.

IP address 1st bit 2nd bit 3rd bit 4th bit 5th bit 6th bit 7th bit 8th bit
128 64 32 16 8 4 2 1
162 1 0 1 0 0 0 1 0
6 0 0 0 0 0 1 1 0
34 0 0 1 0 0 0 1 0
87 0 1 0 1 0 1 1 1

This IP address belongs to class B and Its subnet mask is 255.255.0.0

dotted-decimal notation of IP address 162.6.34.87 is given below

10100010.00000110.00100010.01010111

6.  Convert 182.5.3.6 into dotted-decimal notation and also identify subnet mask or class of this IP address.

IP address 1st bit 2nd bit 3rd bit 4th bit 5th bit 6th bit 7th bit 8th bit
128 64 32 16 8 4 2 1
182 1 0 1 1 0 1 1 0
5 0 0 0 0 0 1 0 1
3 0 0 0 0 0 0 1 1
6 0 0 0 0 0 1 1 0

This IP address belongs to class B and Its subnet mask is 255.255.0.0

dotted-decimal notation of IP address 182.5.3.6 is given below

10110110.00000101.00000011.00000110

7.  Convert 194.54.6.34 into dotted-decimal notation and also identify subnet mask or class of this IP address.

IP address 1st bit 2nd bit 3rd bit 4th bit 5th bit 6th bit 7th bit 8th bit
128 64 32 16 8 4 2 1
194 1 1 0 0 0 0 1 0
54 0 0 1 1 0 1 1 0
6 0 0 0 0 0 1 1 0
34 0 0 1 0 0 0 1 0

This IP address belongs to class C and Its subnet mask is 255.255.255.0

dotted-decimal notation of IP address 194.54.6.34 is given below

11000010.00110110.00000110.00100010

8.  Convert 210.23.56.8 into dotted-decimal notation and also identify subnet mask or class of this IP address.

IP address 1st bit 2nd bit 3rd bit 4th bit 5th bit 6th bit 7th bit 8th bit
128 64 32 16 8 4 2 1
210 1 1 0 1 0 0 1 0
23 0 0 0 1 0 1 1 1
56 0 0 1 1 1 0 0 0
8 0 0 0 0 1 0 0  0

This IP address belongs to class C and Its subnet mask is 255.255.255.0

dotted-decimal notation of IP address 210.23.56.8 is given below

11010010.00010111.00111000.00001000

9.  Convert 218.76.8.3 into dotted-decimal notation and also identify subnet mask or class of this IP address.

IP address 1st bit 2nd bit 3rd bit 4th bit 5th bit 6th bit 7th bit 8th bit
128 64 32 16 8 4 2 1
218 1 1 0 1 1 0 1 0
76 0 1 0 0 1 1 0 0
8 0 0 0 0 1 0 0 0
3 0 0 0 0 0 0 1 1

This IP address belongs to class C and Its subnet mask is 255.255.255.0

dotted-decimal notation of IP address 218.76.8.3 is given below

11011010.01001100.00001000.00000011

10.  Convert 10.0.3.4 into dotted-decimal notation and also identify subnet mask or class of this IP address.

IP address 1st bit 2nd bit 3rd bit 4th bit 5th bit 6th bit 7th bit 8th bit
128 64 32 16 8 4 2 1
10 0 0 0 0 1 0 1 0
0 0 0 0 0 0 0 0 0
3 0 0 0 0 0 0 1 1
4 0 0 0 0 0 1 0 0

This IP address belongs to class A and Its subnet mask is 255.0.0.0

dotted-decimal notation of IP address 10.0.3.4 is given below

00001010.00000000.00000011.00000100

11.  Convert 172.16.0.5 into dotted-decimal notation and also identify subnet mask or class of this IP address.

IP address 1st bit 2nd bit 3rd bit 4th bit 5th bit 6th bit 7th bit 8th bit
128 64 32 16 8 4 2 1
172 1 0 1 0 1 1 0 0
16 0 0 0 1 0 0 0 0
0 0 0 0 0 0 0 0 0
5 0 0 0 0 0 1 0 1

This IP address belongs to class B and Its subnet mask is 255.255.0.0

dotted-decimal notation of IP address 172.16.0.5 is given below

10101100.00010000.00000000.00000101

12.  Convert 192.168.5.9 into dotted-decimal notation and also identify subnet mask or class of this IP address.

IP address 1st bit 2nd bit 3rd bit 4th bit 5th bit 6th bit 7th bit 8th bit
128 64 32 16 8 4 2 1
192 1 1 0 0 0 0 0 0
168 1 0 1 0 1 0 0 0
5 0 0 0 0 0 1 0 1
9 0 0 0 0 1 0 0 1

This IP address belongs to class C and Its subnet mask is 255.255.255.0

dotted-decimal notation of IP address 192.168.5.9 is given below

11000000.10101000.00000101.00001001

                                THAT’S IT

These are some examples of binary conversion of IP version 4 to understand how to convert IP address into dotted-decimal notation easily. If you have any queries regarding this then simply solved out through the comment section and also provide feedback to us because your feedback is valuable for us.

How to configure LACP (Link Aggregation or Ether Channel) on cisco switches

This article is all about how to configure LACP (Link Aggregation or Ether Channel) on Cisco switches. The term link aggregation applies to various methods of combining (aggregating) multiple network connections in parallel in order to increase throughput beyond what a single sustain and also use to provide redundancy in case one of the links should fail. A link aggregation group (LAG) combines a number of physical ports together to make a single high-bandwidth data path.

Actually, link aggregation or Ether Channel is a technology very similar to PAgP which allows two or more than two physical ports to combine and provide a new third single logical port which results in high availability and increased bandwidth. So, now let’s start here how to configure LACP on Cisco switches.

We can also configure Ether Channel on Cisco switches using

1.  Static method

2.  PAgP method

Now to understand this whole process we take lab in cisco packet tracer. In this lab, we take two switches on which we configure LACP or EtherChannel.

How to configure LACP and EtherChannel on cisco switches

We do this whole lab in two parts. In the first part, we configure LACP on both the switches and in the second part we run troubleshooting commands on the switches and verify our configuration.

Now configure LACP on both the switches using below-given command

For switch S1

Switch>enable

Switch#configure terminal

Enter configuration commands, one per line. End with CNTL/Z.

Switch(config)#hostname S1

S1(config)#interface range fa0/1-2



S1(config-if-range)#channel-group 1 mode active

S1(config-if-range)#

Creating a port-channel interface Port-channel 1

%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/1, changed state to down

%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/1, changed state to up

%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/2, changed state to down

%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/2, changed state to up

S1(config-if-range)#channel-protocol lacp

S1(config-if-range)#exit

 

For switch S2

Switch>enable

Switch#configure terminal

Enter configuration commands, one per line. End with CNTL/Z.

Switch(config)#hostname S2

S2(config)#interface range fa0/1-2

S2(config-if-range)#channel-group 1 mode active

S2(config-if-range)#

Creating a port-channel interface Port-channel 1

%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/1, changed state to down

%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/1, changed state to up

%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/2, changed state to down

%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/2, changed state to up

%LINK-5-CHANGED: Interface Port-channel 1, changed state to up

%LINEPROTO-5-UPDOWN: Line protocol on Interface Port-channel 1, changed state to up

S2(config-if-range)#channel-protocol lacp

S2(config-if-range)#exit

 

Now we run troubleshooting command and verify our configuration on both the switches

For switch S1

S1#show etherchannel summary

Flags: D - down P - in port-channel

I - stand-alone s - suspended

H - Hot-standby (LACP only)

R - Layer3 S - Layer2

U - in use f - failed to allocate aggregator

u - unsuitable for bundling

w - waiting to be aggregated

d - default port

Number of channel-groups in use: 1

Number of aggregators: 1

Group Port-channel Protocol Ports

------+-------------+-----------+----------------------------------------------

1 Po1(SU) LACP Fa0/1(P) Fa0/2(P)

 

For switch S2

S2#show etherchannel summary

Flags: D - down P - in port-channel

I - stand-alone s - suspended

H - Hot-standby (LACP only)

R - Layer3 S - Layer2

U - in use f - failed to allocate aggregator

u - unsuitable for bundling

w - waiting to be aggregated

d - default port

Number of channel-groups in use: 1

Number of aggregators: 1

Group Port-channel Protocol Ports

------+-------------+-----------+----------------------------------------------

1 Po1(SU) LACP Fa0/1(P) Fa0/2(P)

THAT’S IT

This is the whole process by which we can easily configure LACP or EtherChannel on Cisco switches. Now If you have any queries regarding this then simply solved out through the comment section and also provide feedback to us. Because your feedback is valuable to us.

How to configure PAgP (Port Aggregation Protocol) on cisco switches

This article is all about how to configure PAGP (Port Aggregation Protocol) on Cisco switches. We all know that there are total three methods are present to configure EtherChannel in Cisco switches. That is static, PAgP and LACP. In the previous tutorial, we configure EtherChannel on switches using the static method. Now in this tutorial, we use PAgP method to configure EtherChannel on Cisco switches.

Port Aggregation Protocol (PAgP) is a cisco system proprietary networking protocol, which is used for automated, logical aggregation of Ethernet switch ports, known as EtherChannel. The PAgP is proprietary to Cisco Systems. A limitation of port aggregation protocol is that all the physical ports in the aggregation group must reside on the same switch. The Advantage of port aggregation protocol is “The line speed of a PAgP port is the total of line speeds of each its physical ports”. So, let’s start here how to configure PAgP on Cisco switches.

Now to understand this whole process we take a lab in cisco packet tracer. In this lab, we take two switches and four pcs.

configure Port Aggregation Protocol on cisco switches

We do this whole lab in two parts. In the first part, we configure PAgP protocol on Cisco switches and also assign an IP address to all the PCs. After that in the second part, we run troubleshooting command on switches and troubleshoot our PAgP configuration on switches.

Now, first of all, we configure PAgP on both the switches using given below command

For switch S1

Switch>enable

Switch#config terminal

Enter configuration commands, one per line. End with CNTL/Z.

Switch(config)#hostname S1

S1(config)#int range fa0/1-2

S1(config-if-range)#channel-group 1 mode desirable

S1(config-if-range)#

Creating a port-channel interface Port-channel 1

%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/1, changed state to down

%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/1, changed state to up

%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/2, changed state to down

%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/2, changed state to up

S1(config-if-range)#exit

For switch S2

Switch>enable

Switch#configure terminal

Enter configuration commands, one per line. End with CNTL/Z.

Switch(config)#hostname S2

S2(config)#int range fa0/1-2

S2(config-if-range)#channel-group 1 mode desirable

S2(config-if-range)#

Creating a port-channel interface Port-channel 1

%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/1, changed state to down

%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/1, changed state to up

%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/2, changed state to down

%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/2, changed state to up

%LINK-5-CHANGED: Interface Port-channel 1, changed state to up

%LINEPROTO-5-UPDOWN: Line protocol on Interface Port-channel 1, changed state to up

S2(config-if-range)#exit

After that now assign IP address on all the PCs according to your need and use ping command to check whether they are communicating with each other or not

 

Now in the second part, we run troubleshooting command on one of the switch and verify our configuration on the switches. Like here we run troubleshooting command on switch S2 as the given below.

S2#show etherchannel summary

Flags: D - down P - in port-channel

I - stand-alone s - suspended

H - Hot-standby (LACP only)

R - Layer3 S - Layer2

U - in use f - failed to allocate aggregator

u - unsuitable for bundling

w - waiting to be aggregated

d - default port

Number of channel-groups in use: 1

Number of aggregators: 1

Group Port-channel Protocol Ports

------+-------------+-----------+----------------------------------------------

1 Po1(SU) PAgP Fa0/1(P) Fa0/2(P)



S2#show etherchannel load-balance

EtherChannel Load-Balancing Operational State (src-mac):

Non-IP: Source MAC address

IPv4: Source MAC address

IPv6: Source MAC address

THAT’S IT

By using above steps we can able to configure EtherChannel on Cisco switches. If you have any queries regarding this feel free to ask through the comment section and also provide feedback to us because your feedback is valuable for us.

Understand how to configure backup route on cisco routers

This article is all about how to configure a backup route on Cisco routers. In this tutorial, we learn about how to configure a backup route on routers, why we use a backup route, where we use a backup route and features of a backup route. We generally use a backup route in companies because the backup router allows the routing device to install a backup route to the management network before the routing protocol process is up and running. If somehow a router’s dynamic protocol gets a problem, it’s a good idea to have a backup route.

That way even when the dynamic protocol messes up, the router will still be functioning. We configure a backup routing easily on a router by changing its administrative value. default administrative value will be given below in the following table with routing protocols.

Routing Protocol Administartive Distance
Directly connected interface      0
Static route      1
EIGRP Summary      5
External Border Gateway Protocol (BGP)      20
Internal EIGRP      90
IGRP      100
OSPF      110
Intermediate System-to-Intermediate System (IS-IS)      115
Routing Information Protocol (RIP)      120
Exterior Gateway Protocol (EGP)      140
On-Demand Routing      160
External EIGRP      170
Internal BGP      200
Unknown      255

A lower administrative distance is preferred over a high distance and a routing source with an administrative distance is never used. So let’s start here how to configure a backup route on a Cisco router.

Now to understand this process we take a lab in cisco packet tracer. In this lab, we take two routers having serial ports in it and two PCs.

how to configure backup route

We do this whole process in three parts in the first part we assign an IP address to all the interfaces of the router and in the second part, we configure a backup route on routers. In a third part, we run troubleshooting commands on routers and verify your routing. So let’s start here how to configure a backup route on Cisco routers.

part 1: – Assign IP address on all the interfaces of the router

For router R1

Router>enable

Router#config t

Enter configuration commands, one per line. End with CNTL/Z.

Router(config)#hostname R1

R1(config)#interface FastEthernet0/0

R1(config-if)#ip address 10.0.0.1 255.0.0.0

R1(config-if)#no shutdown

%LINK-5-CHANGED: Interface FastEthernet0/0, changed state to up

%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/0, changed state to up

R1(config-if)#exit

R1(config)#interface Serial0/0/0

R1(config-if)#ip address 20.0.0.1 255.0.0.0

R1(config-if)#clock rate 64000

R1(config-if)#no shutdown

%LINK-5-CHANGED: Interface Serial0/0/0, changed state to down

R1(config-if)#exit

R1(config)#interface Serial0/0/1

R1(config-if)#ip address 30.0.0.1 255.0.0.0

R1(config-if)#clock rate 64000

R1(config-if)#no shutdown

%LINK-5-CHANGED: Interface Serial0/0/1, changed state to down

R1(config-if)#exit

For router R2

Router>enable

Router#configure terminal

Enter configuration commands, one per line. End with CNTL/Z.

Router(config)#hostname R2

R2(config)#interface FastEthernet0/0

R2(config-if)#ip address 40.0.0.1 255.0.0.0

R2(config-if)#no shutdown

%LINK-5-CHANGED: Interface FastEthernet0/0, changed state to up

%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/0, changed state to up

R2(config-if)#exit

R2(config)#interface Serial0/0/0

R2(config-if)#ip address 20.0.0.2 255.0.0.0

R2(config-if)#no shutdown

%LINK-5-CHANGED: Interface Serial0/0/0, changed state to up

%LINEPROTO-5-UPDOWN: Line protocol on Interface Serial0/0/0, changed state to up

R2(config-if)#exit

R2(config)#interface Serial0/0/1

R2(config-if)#ip address 30.0.0.2 255.0.0.0

R2(config-if)#no shutdown

%LINK-5-CHANGED: Interface Serial0/0/1, changed state to up

%LINEPROTO-5-UPDOWN: Line protocol on Interface Serial0/0/1, changed state to up

R2(config-if)#exit

Part 2: – Configure static backup routing on routers

For router R1

R1(config)#ip route 40.0.0.0 255.0.0.0 20.0.0.2

R1(config)#ip route 40.0.0.0 255.0.0.0 30.0.0.2 10

 

For router R2

R2(config)#ip route 10.0.0.0 255.0.0.0 20.0.0.1

R2(config)#ip route 10.0.0.0 255.0.0.0 30.0.0.1 10

Part 3: – Run troubleshooting command on both the routers and verify our routing

For router R1

R1#show ip route

Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP

D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area

N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2

E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP

i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area

∗  - candidate default, U - per-user static route, o - ODR

P - periodic downloaded static route

Gateway of last resort is not set

C 10.0.0.0/8 is directly connected, FastEthernet0/0

C 20.0.0.0/8 is directly connected, Serial0/0/0

C 30.0.0.0/8 is directly connected, Serial0/0/1

S 40.0.0.0/8 [1/0] via 20.0.0.2

 

For router R2

R2#show ip route

Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP

D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area

N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2

E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP

i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area

∗   - candidate default, U - per-user static route, o - ODR

P - periodic downloaded static route

Gateway of last resort is not set

S 10.0.0.0/8 [1/0] via 20.0.0.1

C 20.0.0.0/8 is directly connected, Serial0/0/0

C 30.0.0.0/8 is directly connected, Serial0/0/1

C 40.0.0.0/8 is directly connected, FastEthernet0/0

 

Now take one of the PC and use ping and tracert command to check whether they are communicating with each other or not

Packet Tracer PC Command Line 1.0

 

PC>ping 40.0.0.2

Pinging 40.0.0.2 with 32 bytes of data:

Reply from 40.0.0.2: bytes=32 time=8ms TTL=126

Reply from 40.0.0.2: bytes=32 time=1ms TTL=126

Reply from 40.0.0.2: bytes=32 time=1ms TTL=126

Reply from 40.0.0.2: bytes=32 time=1ms TTL=126

Ping statistics for 40.0.0.2:

Packets: Sent = 4, Received = 4, Lost = 0 (0% loss),

Approximate round trip times in milli-seconds:

Minimum = 1ms, Maximum = 8ms, Average = 2ms



PC>tracert 40.0.0.2

Tracing route to 40.0.0.2 over a maximum of 30 hops:

1 0 ms 0 ms 0 ms 10.0.0.1

2 0 ms 2 ms 0 ms 20.0.0.2

3 1 ms 1 ms 0 ms 40.0.0.2

Trace complete.

THAT’S IT

This is the whole process for configuring a static backup route on a router. If you have any queries regarding this feel free to ask through the comment section and also provide feedback to us because your feedback is valuable for us.