Learn how to configure default routing on Cisco routers

CCNA

This article is all about how to configure default routing over the Cisco routers in Cisco packet tracer. Now in this tutorial, we learn how to configure default routing on Cisco routers. First of all, we learn about default routing what is it. In computer networking, the default route is a setting on a computer that defines the packet forwarding rules to use when no specific route can be determined for a given Internet protocol (IP) destination address. All packets for destinations not established in the routing table are sent via the default route. So we use default route on routers. It is easy to configure but less secure than others.

Also Read: How to automatic secure your router using the auto secure feature

Now here we take a lab in cisco packet tracer and learn how to configure default routing on Cisco routers. In this lab, we will take three routers which are connected to each other and each router connected to a switch and here each switch connected to a computer.

learn configure default routing on routers

First of all, we assign the IP address to all the interfaces of the routers.

For router R1

— System Configuration Dialog —

Continue with configuration dialog? [yes/no]: no

Press RETURN to get started!

Router>enable

Router#configure terminal

Enter configuration commands, one per line. End with CNTL/Z.

Router(config)#hostname R1

R1(config)#interface FastEthernet0/0

R1(config-if)#ip address 1.0.0.1 255.0.0.0

R1(config-if)#no shutdown

%LINK-5-CHANGED: Interface FastEthernet0/0, changed state to up

%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/0, changed state to up

R1(config-if)#exit

R1(config)#interface FastEthernet0/1

R1(config-if)#ip address 2.0.0.1 255.0.0.0

R1(config-if)#no shutdown

%LINK-5-CHANGED: Interface FastEthernet0/1, changed state to up

R1(config-if)#exit

 

For router R2

— System Configuration Dialog —

Continue with configuration dialog? [yes/no]: no

Press RETURN to get started!

Router>enable

Router#configure terminal

Enter configuration commands, one per line. End with CNTL/Z.

Router(config)#hostname R2

R2(config)#interface FastEthernet0/0

R2(config-if)#ip address 2.0.0.2 255.0.0.0

R2(config-if)#no shutdown

%LINK-5-CHANGED: Interface FastEthernet0/0, changed state to up

%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/0, changed state to up

R2(config-if)#exit

R2(config)#interface FastEthernet0/1

R2(config-if)#ip address 4.0.0.1 255.0.0.0

R2(config-if)#no shutdown

%LINK-5-CHANGED: Interface FastEthernet0/1, changed state to up

R2(config-if)#exit

R2(config)#interface Ethernet0/0/0

R2(config-if)#ip address 3.0.0.1 255.0.0.0

R2(config-if)#no shutdown

%LINK-5-CHANGED: Interface Ethernet0/0/0, changed state to up

%LINEPROTO-5-UPDOWN: Line protocol on Interface Ethernet0/0/0, changed state to up

R2(config-if)#exit

 

For router R3

— System Configuration Dialog —

Continue with configuration dialog? [yes/no]: no

Press RETURN to get started!

Router>enable

Router#configure terminal

Enter configuration commands, one per line. End with CNTL/Z.

Router(config)#hostname R3

R3(config)#interface FastEthernet0/0

R3(config-if)#ip address 4.0.0.2 255.0.0.0

R3(config-if)#no shutdown

%LINK-5-CHANGED: Interface FastEthernet0/0, changed state to up

%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/0, changed state to up

R3(config-if)#exit

R3(config)#interface FastEthernet0/1

R3(config-if)#ip address 5.0.0.1 255.0.0.0

R3(config-if)#no shutdown

%LINK-5-CHANGED: Interface FastEthernet0/1, changed state to up

%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/1, changed state to up

R3(config-if)#exit

Now IP address will be assigned to all the interfaces of the routers and routers will be up by no shutdown command

 

Now configure default routing on all the routers using given below codes

For router R1

R1(config)#ip route 0.0.0.0 0.0.0.0 2.0.0.2

R1(config)#ip route 0.0.0.0 0.0.0.0 2.0.0.2

R1(config)#ip route 0.0.0.0 0.0.0.0 2.0.0.2

 

For router R2

R2(config)#ip route 0.0.0.0 0.0.0.0 2.0.0.1

R2(config)#ip route 0.0.0.0 0.0.0.0 4.0.0.2

 

For router R3

R3(config)#ip route 0.0.0.0 0.0.0.0 4.0.0.1

R3(config)#ip route 0.0.0.0 0.0.0.0 4.0.0.1

R3(config)#ip route 0.0.0.0 0.0.0.0 4.0.0.1

Now default routing will be configured on all over the routers now first of all give IP addresses to all the PCs according to their networks and then check that they are communicate with each other or not.

Also Read:  How to configure telnet on Cisco switches

Now to check default route on your router use below-given commands and verify your routing by these troubleshooting commands on your router.

For router R1

R1#show ip route

Codes: C – connected, S – static, I – IGRP, R – RIP, M – mobile, B – BGP

D – EIGRP, EX – EIGRP external, O – OSPF, IA – OSPF inter area

N1 – OSPF NSSA external type 1, N2 – OSPF NSSA external type 2

E1 – OSPF external type 1, E2 – OSPF external type 2, E – EGP

i – IS-IS, L1 – IS-IS level-1, L2 – IS-IS level-2, ia – IS-IS inter area

    • candidate default, U – per-user static route, o – ODR

P – periodic downloaded static route

Gateway of last resort is 2.0.0.2 to network 0.0.0.0

C 1.0.0.0/8 is directly connected, FastEthernet0/0

C 2.0.0.0/8 is directly connected, FastEthernet0/1

S* 0.0.0.0/0 [1/0] via 2.0.0.2

 

For router R2

R2#show ip route

Codes: C – connected, S – static, I – IGRP, R – RIP, M – mobile, B – BGP

D – EIGRP, EX – EIGRP external, O – OSPF, IA – OSPF inter area

N1 – OSPF NSSA external type 1, N2 – OSPF NSSA external type 2

E1 – OSPF external type 1, E2 – OSPF external type 2, E – EGP

i – IS-IS, L1 – IS-IS level-1, L2 – IS-IS level-2, ia – IS-IS inter area

    • candidate default, U – per-user static route, o – ODR

P – periodic downloaded static route

Gateway of last resort is 2.0.0.1 to network 0.0.0.0

C 2.0.0.0/8 is directly connected, FastEthernet0/0

C 3.0.0.0/8 is directly connected, Ethernet0/0/0

C 4.0.0.0/8 is directly connected, FastEthernet0/1

S* 0.0.0.0/0 [1/0] via 2.0.0.1

[1/0] via 4.0.0.2

 

For router R3

R3#show ip route

Codes: C – connected, S – static, I – IGRP, R – RIP, M – mobile, B – BGP

D – EIGRP, EX – EIGRP external, O – OSPF, IA – OSPF inter area

N1 – OSPF NSSA external type 1, N2 – OSPF NSSA external type 2

E1 – OSPF external type 1, E2 – OSPF external type 2, E – EGP

i – IS-IS, L1 – IS-IS level-1, L2 – IS-IS level-2, ia – IS-IS inter area

    • candidate default, U – per-user static route, o – ODR

P – periodic downloaded static route

Gateway of last resort is 4.0.0.1 to network 0.0.0.0

C 4.0.0.0/8 is directly connected, FastEthernet0/0

C 5.0.0.0/8 is directly connected, FastEthernet0/1

S* 0.0.0.0/0 [1/0] via 4.0.0.1

THAT’S IT

Now here you can see that in S* will be shown on every router troubleshooting command that means your default route is configured on your router. If you have any problem regarding this solved out through comment section.

If you want to show this process in video format click on given below link and go to my youtube channel Technohelper24 com

Your thoughts about this?

This site uses Akismet to reduce spam. Learn how your comment data is processed.